t

【重要】Apache Tomcat脆弱性対策のお知らせ

APACHE

平素より、弊社スカイアーチネットワークスのサービスをご利用頂きまして、誠に有難う御座います。

Apache Tomcatにて脆弱性が報告されました。脆弱性情報と対応に関して下記の通り報告させて頂きます。


Apache Tomcat に安全でないデシリアライゼーションの問題

概要

The Apache Software Foundation から、Apache Tomcat の脆弱性に対するアップデートが公開されました。

影響を受けるシステム

  • Apache Tomcat 10.0.0-M1 から 10.0.0-M4 まで
  • Apache Tomcat 9.0.0.M1 から 9.0.34 まで
  • Apache Tomcat 8.5.0 から 8.5.54 まで
  • Apache Tomcat 7.0.0 から 7.0.103 まで

詳細情報

The Apache Software Foundation から、Apache Tomcat の脆弱性に対するアップデートが公開されました。

信頼できないデータのデシリアライズ (CWE-502) - CVE-2020-9484
想定される影響
デシリアライズ対象データの検証が適切に行われていないことに起因して、遠隔の第三者により任意のバイトコードを実行される可能性があります。

対策方法

アップデートする
開発者が提供する情報をもとに、使用しているバージョンの最新版にアップデートしてください。
開発者は、本脆弱性を修正した以下のバージョンをリリースしています。

  • Apache Tomcat 10.0.0-M5
  • Apache Tomcat 9.0.35
  • Apache Tomcat 8.5.55
  • Apache Tomcat 7.0.104

ワークアラウンドを実施する

以下の回避策を適用することで、本脆弱性の影響を軽減することが可能です。

PersistenceManager において sessionAttributeValueClassNameFilter の値を適切に設定し、アプリケーションが提供する attribute だけがシリアライズおよびデシリアライズされるようにする

備考

お電話でのご相談・お問い合わせはこちら

お電話でのご相談・お問い合わせはこちら 03-6743-1100 価格や仕様、サービスの詳細などのお問合せから、クラウド導入についてのわからないことなどまで。

価格・仕様などサービス詳細のお問い合わせや、クラウド導入の分からないことなど、お気軽にご連絡ください。

フォームでのお問い合わせ(無料)