t

【重要】Apache Struts 2 にサービス運用妨害 (DoS) の脆弱性

APACHE

平素より、弊社スカイアーチネットワークスのサービスをご利用頂きまして、誠に有難う御座います。

Apache Struts2にて脆弱性が報告されました。脆弱性情報と対応に関して下記の通り報告させて頂きます。

概要

Apache Struts 2 にはサービス運用妨害 (DoS) の脆弱性が存在します。

影響を受けるシステム

  • Struts 2.0.0 から 2.5.20 までのバージョン

詳細情報

Apache Struts 2 にはサービス運用妨害 (DoS) (CWE-400) の脆弱性が存在します。

想定される影響

第三者によって、サービス運用妨害 (DoS) 攻撃を受ける可能性があります。

対策方法

アップデートする
開発者が提供する情報をもとに、最新版へアップデートしてください。

ワークアラウンドを実施する

struts-default.xml の定数 struts.excludedPackageNames の Value 属性に java.io. と java.nio. を追加してください
ただし、The Apache Software Foundation はワークアラウンドの実施よりもアップデートの実施を推奨しています。

備考

最終更新日

2020.09.01

お電話でのご相談・お問い合わせはこちら

お電話でのご相談・お問い合わせはこちら 03-6743-1100 価格や仕様、サービスの詳細などのお問合せから、クラウド導入についてのわからないことなどまで。

価格・仕様などサービス詳細のお問い合わせや、クラウド導入の分からないことなど、お気軽にご連絡ください。

フォームでのお問い合わせ(無料)